#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\R\d*[.,\s\d]+"
Local $sString = "R4,491.25" & @CRLF & _
"asdasd6466546.6464" & @CRLF & _
"asdaR64.54asd" & @CRLF & _
"4asdas" & @CRLF & _
"dasd" & @CRLF & _
"afssad" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")