$re = '/\R\d*[.,\s\d]+/';
$str = 'R4,491.25
asdasd6466546.6464
asdaR64.54asd
4asdas
dasd
afssad
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);