package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\R\d*[.,\s\d]+`)
var str = `R4,491.25
asdasd6466546.6464
asdaR64.54asd
4asdas
dasd
afssad
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}