const regex = /\R\d*[.,\s\d]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\R\\d*[.,\\s\\d]+', '')
const str = `R4,491.25
asdasd6466546.6464
asdaR64.54asd
4asdas
dasd
afssad
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}