re = /\R\d*[.,\s\d]+/
str = 'R4,491.25
asdasd6466546.6464
asdaR64.54asd
4asdas
dasd
afssad
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end