import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\R\\d*[.,\\s\\d]+";
final String string = "R4,491.25\n"
+ "asdasd6466546.6464\n"
+ "asdaR64.54asd\n"
+ "4asdas\n"
+ "dasd\n"
+ "afssad\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}