import Foundation
let pattern = #"\R\d*[.,\s\d]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
R4,491.25
asdasd6466546.6464
asdaR64.54asd
4asdas
dasd
afssad
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}