# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[quotemsg data-username=\"(.*?)\"\](.*?)\[\/quotemsg\]/$2/s;t' <<< "[quotemsg data-username=\"Александр З\"]Здравствуйте,
Подскажите как можно в исходном коде статей расставить классы для заголовков H2?
Статей много - вручную не вариант.
По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс.
Например классы header1, header2, header13
Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы"