$re = '~\[quotemsg data-username=\"(.*?)\"\](.*?)\[/quotemsg\]~s';
$str = '[quotemsg data-username="Александр З"]Здравствуйте,
Подскажите как можно в исходном коде статей расставить классы для заголовков H2?
Статей много - вручную не вариант.
По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс.
Например классы header1, header2, header13
Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы';
$subst = "$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;