import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[quotemsg data-username=\\\"(.*?)\\\"\\](.*?)\\[/quotemsg\\]";
final String string = "[quotemsg data-username=\"Александр З\"]Здравствуйте,\n\n"
+ "Подскажите как можно в исходном коде статей расставить классы для заголовков H2?\n"
+ "Статей много - вручную не вариант.\n\n"
+ "По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс.\n"
+ "Например классы header1, header2, header13\n\n"
+ "Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}