import re
regex = re.compile(r"\[quotemsg data-username=\"(.*?)\"\](.*?)\[/quotemsg\]", flags=re.DOTALL)
test_str = ("[quotemsg data-username=\"Александр З\"]Здравствуйте,\n\n"
"Подскажите как можно в исходном коде статей расставить классы для заголовков H2?\n"
"Статей много - вручную не вариант.\n\n"
"По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс.\n"
"Например классы header1, header2, header13\n\n"
"Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы")
subst = "$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)