#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\[quotemsg data-username=\"(.*?)\"\](.*?)\[/quotemsg\]"
Local $sString = "[quotemsg data-username="Александр З"]Здравствуйте," & @CRLF & _
"" & @CRLF & _
"Подскажите как можно в исходном коде статей расставить классы для заголовков H2?" & @CRLF & _
"Статей много - вручную не вариант." & @CRLF & _
"" & @CRLF & _
"По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс." & @CRLF & _
"Например классы header1, header2, header13" & @CRLF & _
"" & @CRLF & _
"Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)