// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)\[quotemsg data-username=\"(.*?)\"\](.*?)\[/quotemsg\]"#).unwrap();
let string = "[quotemsg data-username=\"Александр З\"]Здравствуйте,
Подскажите как можно в исходном коде статей расставить классы для заголовков H2?
Статей много - вручную не вариант.
По сути надо в цикле пройтись по всем материалам и при встрече заголовка, в зависимости от его порядка в тексте, дать ему класс.
Например классы header1, header2, header13
Сказать легко - сделать не могу[/quotemsg]Отвечаю на сообщение с первой страницы";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}