#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\.error\..*|^second.*\.log$|.*FF[Pp][Cc]\.log$"
Local $sString = "first.error.log" & @CRLF & _
"second1.log" & @CRLF & _
"second2.log" & @CRLF & _
"FFFpc.log" & @CRLF & _
"TR.den.log" & @CRLF & _
"bla.error.log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")