re = /.*\.error\..*|^second.*\.log$|.*FF[Pp][Cc]\.log$/m
str = 'first.error.log
second1.log
second2.log
FFFpc.log
TR.den.log
bla.error.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end