using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.error\..*|^second.*\.log$|.*FF[Pp][Cc]\.log$";
string input = @"first.error.log
second1.log
second2.log
FFFpc.log
TR.den.log
bla.error.log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}