$re = '/.*\.error\..*|^second.*\.log$|.*FF[Pp][Cc]\.log$/m';
$str = 'first.error.log
second1.log
second2.log
FFFpc.log
TR.den.log
bla.error.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);