const regex = new RegExp('.*\\.error\\..*|^second.*\\.log$|.*FF[Pp][Cc]\\.log$', 'gm')
const str = `first.error.log
second1.log
second2.log
FFFpc.log
TR.den.log
bla.error.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}