// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\.error\..*|^second.*\.log$|.*FF[Pp][Cc]\.log$").unwrap();
let string = "first.error.log
second1.log
second2.log
FFFpc.log
TR.den.log
bla.error.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}