package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\.error\..*|^second.*\.log$|.*FF[Pp][Cc]\.log$`)
var str = `first.error.log
second1.log
second2.log
FFFpc.log
TR.den.log
bla.error.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}