# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)/<pre>\n$1\n<\/pre>/gm;t' <<< "Here is the code:
String name = \"Jon\";
System.out.println(\"Hello \"+name);
output:
Hello Jon"