use strict;
my $str = 'Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon';
my $regex = qr/((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)/mp;
my $subst = '<pre>\\n$1\\n</pre>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";