package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)`)
var str = `Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon`
var substitution = "<pre>\n$1\n</pre>"
fmt.Println(re.ReplaceAllString(str, substitution))
}