re = /((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)/m
str = 'Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon'
subst = '<pre>\\n$1\\n</pre>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result