#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)"
Local $sString = "Here is the code:" & @CRLF & _
"" & @CRLF & _
" String name = "Jon";" & @CRLF & _
" System.out.println("Hello "+name);" & @CRLF & _
"" & @CRLF & _
"output:" & @CRLF & _
"" & @CRLF & _
" Hello Jon"
Local $sSubst = "<pre>\n$1\n</pre>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)