$re = '/((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)/m';
$str = 'Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon';
$subst = "<pre>\n$1\n</pre>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;