import Foundation
let pattern = #"((?:^ {4}\S.*$\r?\n)*^ {4}\S.*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<pre>\n$1\n</pre>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)