#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:[^,"'\n]*(?:(?:"[^"\n]*")|(?:'[^'\n]*'))[^,"'\n]*)+)|[^,\n]+"
Local $sString = "abcd,efgh, ijkl" & @CRLF & _
"abcd, efgh, ij"k,l", mnop, 'q,rs't" & @CRLF & _
"abcd, efgh, ij"k,l',a"', mnop, 'q,r,s't" & @CRLF & _
"abcd, efgh, ij"k,l", mnop, 'q,rs't" & @CRLF & _
"'q, rs't" & @CRLF & _
""'q,rs't, ij"k, l""" & @CRLF & _
""'q,rs't, ij"k"'q,rs't, ij"k, l""" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")