$re = '/(?:(?:[^,"\'\n]*(?:(?:"[^"\n]*")|(?:\'[^\'\n]*\'))[^,"\'\n]*)+)|[^,\n]+/m';
$str = 'abcd,efgh, ijkl
abcd, efgh, ij"k,l", mnop, \'q,rs\'t
abcd, efgh, ij"k,l\',a"\', mnop, \'q,r,s\'t
abcd, efgh, ij"k,l", mnop, \'q,rs\'t
\'q, rs\'t
"\'q,rs\'t, ij"k, l""
"\'q,rs\'t, ij"k"\'q,rs\'t, ij"k, l""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);