package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:[^,"'\n]*(?:(?:"[^"\n]*")|(?:'[^'\n]*'))[^,"'\n]*)+)|[^,\n]+`)
var str = `abcd,efgh, ijkl
abcd, efgh, ij"k,l", mnop, 'q,rs't
abcd, efgh, ij"k,l',a"', mnop, 'q,r,s't
abcd, efgh, ij"k,l", mnop, 'q,rs't
'q, rs't
"'q,rs't, ij"k, l""
"'q,rs't, ij"k"'q,rs't, ij"k, l""
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}