#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*"
Local $sString = "EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):" & @CRLF & _
"9999999999999999999999999999" & @CRLF & _
"119111111111" & @CRLF & _
"123456789123456789" & @CRLF & _
"" & @CRLF & _
"EXEMPLOS NA PERGUNTA:" & @CRLF & _
"993345987" & @CRLF & _
"9 93345987" & @CRLF & _
"(21)932324343" & @CRLF & _
"(21)9 3232 4343" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")