import re
regex = re.compile(r".*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*", flags=re.MULTILINE)
test_str = ("EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):\n"
"9999999999999999999999999999\n"
"119111111111\n"
"123456789123456789\n\n"
"EXEMPLOS NA PERGUNTA:\n"
"993345987\n"
"9 93345987\n"
"(21)932324343\n"
"(21)9 3232 4343\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")