import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*";
final String string = "EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):\n"
+ "9999999999999999999999999999\n"
+ "119111111111\n"
+ "123456789123456789\n\n"
+ "EXEMPLOS NA PERGUNTA:\n"
+ "993345987\n"
+ "9 93345987\n"
+ "(21)932324343\n"
+ "(21)9 3232 4343\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}