const regex = /.*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*', 'gm')
const str = `EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):
9999999999999999999999999999
119111111111
123456789123456789
EXEMPLOS NA PERGUNTA:
993345987
9 93345987
(21)932324343
(21)9 3232 4343
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}