// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*").unwrap();
let string = "EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):
9999999999999999999999999999
119111111111
123456789123456789
EXEMPLOS NA PERGUNTA:
993345987
9 93345987
(21)932324343
(21)9 3232 4343
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}