use strict;
my $str = 'EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):
9999999999999999999999999999
119111111111
123456789123456789
EXEMPLOS NA PERGUNTA:
993345987
9 93345987
(21)932324343
(21)9 3232 4343
';
my $regex = qr/.*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}