using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[0-9]{2}9[0-9]{8}.*|.*[0-9]{2} 9 [0-9]{4} [0-9]{4}.*";
string input = @"EXEMPLOS QUE NÃO SÃO NÚMEROS DE TELEFONE (ZAP):
9999999999999999999999999999
119111111111
123456789123456789
EXEMPLOS NA PERGUNTA:
993345987
9 93345987
(21)932324343
(21)9 3232 4343
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}