using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!(.)\1)(?:[rs]{1,2}|[as]{1,2})\b";
string input = @"r
s
a
rs
sr
as
sa
ss
rr
aa
ra - ar
asr - ars - sra - sar - rsa - ras ";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}