const regex = /\b(?!(.)\1)(?:[rs]{1,2}|[as]{1,2})\b/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(.)\\1)(?:[rs]{1,2}|[as]{1,2})\\b', 'gu')
const str = `r
s
a
rs
sr
as
sa
ss
rr
aa
ra - ar
asr - ars - sra - sar - rsa - ras `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}