re = /\b(?!(.)\1)(?:[rs]{1,2}|[as]{1,2})\b/
str = 'r
s
a
rs
sr
as
sa
ss
rr
aa
ra - ar
asr - ars - sra - sar - rsa - ras '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end