import re
regex = re.compile(r"\b(?!(.)\1)(?:[rs]{1,2}|[as]{1,2})\b", flags=re.UNICODE)
test_str = ("r\n"
"s\n"
"a\n"
"rs\n"
"sr\n"
"as\n"
"sa\n"
"ss\n"
"rr\n"
"aa\n"
"ra - ar\n"
"asr - ars - sra - sar - rsa - ras ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")