import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!(.)\\1)(?:[rs]{1,2}|[as]{1,2})\\b";
final String string = "r\n"
+ "s\n"
+ "a\n"
+ "rs\n"
+ "sr\n"
+ "as\n"
+ "sa\n"
+ "ss\n"
+ "rr\n"
+ "aa\n"
+ "ra - ar\n"
+ "asr - ars - sra - sar - rsa - ras ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}