#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>"
Local $sString = "<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo'<>bar</h4>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)