$re = '/<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>/m';
$str = '<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo\'<>bar</h4>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;