re = /<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>/m
str = '<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo\'<>bar</h4>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result