const regex = /<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(h[2-4])>((?:(?!<h\\d+\\b).)+?)<\\\/\\1>', 'gm')
const str = `<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo'<>bar</h4>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);