import re
regex = re.compile(r"<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>", flags=re.MULTILINE)
test_str = "<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo'<>bar</h4>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)