import Foundation
let pattern = #"<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo'<>bar</h4>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)