# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:0*)(\d+(\.(25|5|75))?)(?:0*)$/$1/gm;t' <<< "1
01
1.25
01.25
0
0.25
0.50
0.5
0.750
000
0001.111
0001.5
.25
01234
"