import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0*)(\\d+(\\.(25|5|75))?)(?:0*)$";
final String string = "1\n"
+ "01\n"
+ "1.25\n"
+ "01.25\n"
+ "0\n"
+ "0.25\n"
+ "0.50\n"
+ "0.5\n"
+ "0.750\n"
+ "000\n"
+ "0001.111\n"
+ "0001.5\n"
+ ".25\n"
+ "01234\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}